Author Topic: blinker issue  (Read 345 times)

0 Members and 1 Guest are viewing this topic.

Offline Serpiko

  • Member
  • **
  • Posts: 216
  • Referrals: 0
blinker issue
« on: October 30, 2011, 05:52:08 AM »
Hi, after sitting a couple of days in the rain the blinkers of my T/A don't work and when I press the brake pedal both blinkers indicators on the dash go on.
First question: considering that my experience in mechanics ends with Lego (but I really want to learn), can I fix it or should I let an experienced mechanic do the job?
If you answer yes to the first question than what the hell is wrong with the indicator and how can I fix it?
Thanks  :)
"Maybe I am a dinosaur, but I am a Tyrannosaurus Rex baby", -Lemmy

Offline hada76

  • Adv. Member
  • ****
  • Posts: 2808
  • '79 WS6 W72 M21
  • Referrals: 0
Re: blinker issue
« Reply #1 on: October 30, 2011, 12:17:36 PM »
both indicators while braking usually means hazards are on.            (i hate electrical issues)






« Last Edit: October 30, 2011, 12:19:48 PM by hada76 »
'76 T/A 455 4sp   sold
'78 T/A Y88 auto  sold
'79 T/A WS6 4sp
'70 Z/28 4sp

jeff

Offline Serpiko

  • Member
  • **
  • Posts: 216
  • Referrals: 0
Re: blinker issue
« Reply #2 on: November 01, 2011, 04:07:32 PM »
Thanks for the suggestion hada76 I actually went to check the car today and you where right the hazard (not working) was on, the blinkers are fine is only the hazard the issue. Man was the mechanic who had my car for a look totally incompetent?! He told me the blinker was not working....

For the hazard might just be a fuse? I also can hear for a fraction of a second the horn when I switch the engine off....

"Maybe I am a dinosaur, but I am a Tyrannosaurus Rex baby", -Lemmy