Author Topic: Went for cruise to Crawford bay aug 3  (Read 1330 times)

0 Members and 1 Guest are viewing this topic.

Offline RainMan

  • Lifetime Member
  • *****
  • Posts: 5401
  • Rick
  • Referrals: 0
Went for cruise to Crawford bay aug 3
« on: August 06, 2012, 01:41:29 AM »
Incredibly beautiful drive heading there ,but arrived 4 hours to late as the sun was to far west to get proper lighting on the Marty . Was nice going for a drive though ,even if was in the high 90's







« Last Edit: August 06, 2012, 03:17:03 AM by RainMan »

Offline firebird79_00

  • Sr. Member
  • ***
  • Posts: 1133
  • Referrals: 0
Re: Went for cruise to Crawford bay aug 3
« Reply #1 on: August 06, 2012, 06:13:31 PM »
Looks good man, maybe we could meet up sometime this month and go for a drive....as long as your good with me bringing a Mustang lol
1977 Firebird Clone
6.6L.....soon

Offline Brewster

  • Jr. Member
  • *
  • Posts: 91
  • Referrals: 0
Re: Went for cruise to Crawford bay aug 3
« Reply #2 on: August 06, 2012, 07:58:17 PM »
Nice pictures!

Offline RainMan

  • Lifetime Member
  • *****
  • Posts: 5401
  • Rick
  • Referrals: 0
Re: Went for cruise to Crawford bay aug 3
« Reply #3 on: August 06, 2012, 08:13:09 PM »
Looks good man, maybe we could meet up sometime this month and go for a drive....as long as your good with me bringing a Mustang lol
Well we could park your Mustang in the alley behind my house  and go cruising in the Marty lol
« Last Edit: August 06, 2012, 10:40:18 PM by RainMan »