Author Topic: 1980 trans am head lights  (Read 2327 times)

0 Members and 1 Guest are viewing this topic.

Offline dodgeram106

  • Member
  • **
  • Posts: 416
  • T/A
  • Referrals: 0
1980 trans am head lights
« on: March 12, 2015, 08:21:30 PM »
I just bought a 1980 Trans Am and got it running....The headlight's don't work and I'm not getting any power to the headlight switch,The turn signal's work in the back when I turn them on but not the front,All the fuses are working.....

Offline tata

  • Sr. Member
  • ***
  • Posts: 609
  • Referrals: 1
Re: 1980 trans am head lights
« Reply #1 on: March 13, 2015, 09:06:41 PM »
Did you check the ground strap on passenger side nose clip.?

Offline tata

  • Sr. Member
  • ***
  • Posts: 609
  • Referrals: 1
Re: 1980 trans am head lights
« Reply #2 on: March 13, 2015, 09:08:23 PM »
Opps read that wrong

Offline ta78w72

  • Lifetime Member
  • *****
  • Posts: 6297
  • Referrals: 0
Re: 1980 trans am head lights
« Reply #3 on: March 14, 2015, 05:43:10 PM »
There is no fuse for the headlights.  The circuit is protected with a fusible link.  If no power at the switch, check to see if there is power coming into the cabin for that circuit.  You can check at the bulkhead connectors.  If you have a service manual it will tell you which one to check.  If no power there, it's probably the fusible line.  Pretty easy fix.


Offline dodgeram106

  • Member
  • **
  • Posts: 416
  • T/A
  • Referrals: 0
Re: 1980 trans am head lights
« Reply #4 on: March 15, 2015, 09:55:34 PM »
Ok,I did more checking today and pulled the bulkhead apart on the outside.I have power going into it from 2 wires both are black and red one big and one small,black with red strip and red with black strip the connection's are clean.Not all the fuses are getting power,NO tail light's,No dash light's,No brake light's or lighter...The wipers,turn signals in back work,gas guage,volt guage work..Ok for the big deal((All the A/C wires have been removed,all cruise control removed,The motor has been changed to a Pontiac 350 and the only wires going to the starter are positive battery cable and ignition wire. There are no fusible links anywhere to be found in the wiring so all that was changed from stock.Only one wire going to the distributer for power and no tach wire.If the 80 model had a computer it doesn't any more this is the old school wiring set up...350 motor,Edelbrock intake and carb,long tube stainless steel header's,Acell cap coil and wire's,and dual electric fan's with a flex fan.

Offline tata

  • Sr. Member
  • ***
  • Posts: 609
  • Referrals: 1
Re: 1980 trans am head lights
« Reply #5 on: March 17, 2015, 05:53:56 AM »

Offline tata

  • Sr. Member
  • ***
  • Posts: 609
  • Referrals: 1
Re: 1980 trans am head lights
« Reply #6 on: March 17, 2015, 05:56:26 AM »
I do have an 80 in the shop, if you need pics just ask. But it did have an engine swap so it might not be all there either.

Offline dodgeram106

  • Member
  • **
  • Posts: 416
  • T/A
  • Referrals: 0
Re: 1980 trans am head lights
« Reply #7 on: March 18, 2015, 02:28:00 AM »
Thanks for the link,I did more checking today and found 2 broken wires that go into the rear harness so I will fix them and have brake and tail lights.I hate to say this but,I found a plug on the outside fire wall with a large red wire and smaller brown wire that went no where.The red wire has constant power so I routed it inside to the head light switch and spliced it into it and now I have all lights in the front.The only fuse now not getting power is the instrument cluster light's.That guy that was redoing the car made a mess out of the wiring cutting everything out.I will try and post pics soon of what I'm working on.....Thank's again for all the help everyone and keep the ideas comeing.....

Offline dodgeram106

  • Member
  • **
  • Posts: 416
  • T/A
  • Referrals: 0
Re: 1980 trans am head lights
« Reply #8 on: March 18, 2015, 03:53:04 PM »
fixed the broken wires that go to the back and now my left tail light won't go off.Two wires coming out of the tail light harness have power all the time....This sucks you fix one thing and 100 more keep poping up........FOR SALE....1980 Trans Am

Offline tata

  • Sr. Member
  • ***
  • Posts: 609
  • Referrals: 1
Re: 1980 trans am head lights
« Reply #9 on: March 19, 2015, 07:19:30 AM »
Did you take the cluster out yet?

Offline dodgeram106

  • Member
  • **
  • Posts: 416
  • T/A
  • Referrals: 0
Re: 1980 trans am head lights
« Reply #10 on: March 22, 2015, 01:46:38 AM »
No I didn't take it out just a lot of checking over things more..He had the brake lights pluged into a switch that was just hanging there not in anything but was close to the E-brake..I thought maybe it was the E-brake button but no,it was another brake light switch and there was 2 already in the mounts at the pedal.So I pulled one of them out and put this one in the spot so now I have brake lights.Thats why I had power going into the 2 wires all the time and I took the other one out that went to the cruise because it has no cruise anymore.....Any way's, I have everything working now after all that. ;D
« Last Edit: March 22, 2015, 01:53:36 AM by dodgeram106 »