Author Topic: first visit. charging problem  (Read 994 times)

0 Members and 1 Guest are viewing this topic.

Offline 2015catman

  • Jr. Member
  • *
  • Posts: 1
  • Referrals: 0
first visit. charging problem
« on: November 10, 2015, 12:55:06 PM »
My daughter brought her 1984 Trans Am over for me to look at. She just bought it. Had a mechanic install a new alternator. Only charges at 12 volts with everything off. I took the alternator to Autozone and they put it on a machine and said it was charging at 15 volts. Put it back on and started checking wiring. All wiring seems to be alright. Took all wires off and cleaned connections and added dielectric grease. 12.5 volts without a load. Add a load and it goes below 12 volts. Added a ground from the block to the frame. Stopped the voltage pull down under load but still only 12.5 volts. New battery. Added another wire from battery to B on the alternator. New wire from B to field plug hot. Still no charge. The only wire I didn't replace was the field to the switch. It has battery voltage. Should it have less voltage because it runs through the carb heater relay????  Even put another alternator of my chevy that was charging 14.5 volts and it only put out 12.5 on the Trans Am. Trans Am alternator only puts out 12.5 when put on my chevy. I'm out of ideas.

Offline ta78w72

  • Lifetime Member
  • *****
  • Posts: 6297
  • Referrals: 0
Re: first visit. charging problem
« Reply #1 on: November 11, 2015, 01:15:42 PM »
If the field wire to the switch is bad the alternator won't charge the battery.  I've seen them burnt at the switch on second gen birds.

Offline gilbertsta

  • Sr. Member
  • ***
  • Posts: 1125
  • "Live Like You Are Dying"
  • Referrals: 0
Re: first visit. charging problem
« Reply #2 on: November 16, 2015, 03:46:50 PM »
Did you check the charge at the alternator? Also did you check the pulley size?