Author Topic: Electical Troubleshooting Expert Needed in FL  (Read 40 times)

0 Members and 1 Guest are viewing this topic.

Offline TA400FL

  • Jr. Member
  • *
  • Posts: 40
  • Referrals: 0
Electical Troubleshooting Expert Needed in FL
« on: February 10, 2018, 08:50:38 PM »
Hello fellow T/A Brethren.
I just got the battery installed in my 78 TA after 3-1/2 years of restoration.  I am an average electrical troubleshooter.  Much better at boats actually.  I got a real mess going on.  Check out the following issues I have found so far.

1)  Only the left side of the gauge lights work.  I put all new bulbs in and all looked good.  Circuit panel looked good.  I jumped a clean ground to the gauge cluster and it didn't help.  And I have that small ground strap connected between the light switch and gauge housing.

2)  The turn signals flash but no indicator lights at all.  Hazards flash but no indicator lights.

3)  Light for temp control panel does not work.

4)  The fan blower is turning on when I turn the Key to Acc position.  It is running at low and nothing changes when I move the fan switch to any of the higher speeds.  The switch and whole A/C control has been completely restored with new components.

5)  The horn does not work.  Checked the Green wire from the steering column connector and no power when activating horn at wheel so it doesn't appear that the relay is even getting the horn signal.  According to the wiring diagram I have, the Green is the signal from horn button.  I had the whole steering column apart.  Cleaned everything.  Looked perfect when I put it back together.

I am guessing that most of these things are ground related but I just can't physically troubleshoot anymore.  I tore a ligament in my elbow at work and I can't get under the dash to check on anything.  I am hoping I don't have to tear apart the steering column again.

If anyone knows of an Electrical Guru on the central east coast of FL that knows these cars and can help I will gladly pay for whatever time it takes.