Author Topic: W72 Pontiac 400 question (Valve Covers)  (Read 920 times)

0 Members and 1 Guest are viewing this topic.

Offline dany_boy_1972

  • Jr. Member
  • *
  • Posts: 8
  • Referrals: 0
W72 Pontiac 400 question (Valve Covers)
« on: June 05, 2019, 01:34:11 PM »
I have seen some original W72 400 Motors with chrome valve covers and some with regular 400 valve covers.  I thought that all the W72 had chrome was that not the case?  Thanks

Offline Aus78Formula

  • Adv. Member
  • ****
  • Posts: 2280
  • Referrals: 0
Re: W72 Pontiac 400 question (Valve Covers)
« Reply #1 on: June 06, 2019, 01:57:37 AM »
They are now 40 years old, lots of owners do lots of things.

Offline Maxthe222

  • Jr. Member
  • *
  • Posts: 39
  • Referrals: 0
Re: W72 Pontiac 400 question (Valve Covers)
« Reply #2 on: June 07, 2019, 02:45:07 AM »
All W72's had chromed valve covers. They had specific part number codes on them too.

Offline axxe555

  • Jr. Member
  • *
  • Posts: 11
  • Referrals: 0
Re: W72 Pontiac 400 question (Valve Covers)
« Reply #3 on: August 07, 2019, 06:41:33 PM »
Best of my knowledge, the W72 Pontiac engines came from the factory with chrome valve covers. The W72 engine option came out in 1977, and they also had the L78 Pontiac engine, and they had engine colored valve covers. If original, this was one way to distinquish between the two Pontiac engines.

Offline dany_boy_1972

  • Jr. Member
  • *
  • Posts: 8
  • Referrals: 0
Re: W72 Pontiac 400 question (Valve Covers)
« Reply #4 on: October 18, 2019, 08:05:56 AM »
Thanks for the info!