Author Topic: Quadrajet Primary Idle Screw does not reach Primary Throttle linkage  (Read 245 times)

0 Members and 1 Guest are viewing this topic.

Offline 71-Transam

  • Jr. Member
  • *
  • Posts: 13
  • Referrals: 0
Hi folks, I appreciate any assistance here.   I started my 77 SE trans am for the first time and went to adjust the carb and noticed the primary idle screw or curb idle screw on the drivers side is about 1/4 inch away from the throttle linkage and I cant screw it in enough to even reach the linkage.   I made sure the throttle linkage is all the way back and the primaries are sitting at 90 degrees when I push the linkage to full throttle.   The screw is about 1" long and appears to be the stock screw.    The linkage appears to be okay and the carb was just rebuilt.   Lastly the place where the screw engages the throttle linkage is not sitting straight up and down.  It appears to be rotated about 30 degrees if that make since.   I was hoping someone could look at there carb to see if their linkage connection point is the same.

Once the car is started it appears to be idling fine yet the choke is engaged.

Thanks for any help here
« Last Edit: December 06, 2019, 02:03:26 AM by 71-Transam »

Offline 71-Transam

  • Jr. Member
  • *
  • Posts: 13
  • Referrals: 0
Re: Quadrajet Primary Idle Screw does not reach Primary Throttle linkage
« Reply #1 on: December 06, 2019, 02:33:27 AM »
Problem resolved, had to pry the primary throttle bracket piece that connects with the curb idle screw forward just a bit and that did the trick.