Author Topic: Electrical Issue  (Read 274 times)

0 Members and 1 Guest are viewing this topic.

Offline rbolte10

  • Jr. Member
  • *
  • Posts: 7
  • Referrals: 0
Electrical Issue
« on: May 13, 2020, 02:40:51 PM »
When i turn my head lights on my RPM gauge goes all the way down and my left turn signal light on my dash turns on and stays on not the turn signal itself.  Any help on how to figure out his problem would be great.  Thank you!!

Offline Aus78Formula

  • Adv. Member
  • ****
  • Posts: 2362
  • Referrals: 0
Re: Electrical Issue
« Reply #1 on: May 13, 2020, 07:28:59 PM »
How recent is your circuit board? Sounds like a short based on illumination.

Offline rbolte10

  • Jr. Member
  • *
  • Posts: 7
  • Referrals: 0
Re: Electrical Issue
« Reply #2 on: May 16, 2020, 01:28:02 PM »
Its orginal

Offline 79_455

  • Jr. Member
  • *
  • Posts: 40
  • Referrals: 0
Re: Electrical Issue
« Reply #3 on: May 18, 2020, 12:01:33 AM »
Turn the car on... what happens with the tach?
Once the car is on... Turn on the headlights...
Does that turn signal stay lit?
Activate left  turn and right turn... Do They work like they are supposed to?
Check the hazard switch what happens?

Offline rbolte10

  • Jr. Member
  • *
  • Posts: 7
  • Referrals: 0
Re: Electrical Issue
« Reply #4 on: May 21, 2020, 04:25:09 PM »
The tach goes up and bounces like it should.
when i turn the headlights on the tach goes all the way straight down and doesn't move
the left turn signal turns on and stays on once lights are on
when i activate both turn signals they flash like they should even the left one that is lit up all the time once head lights are on it flashes.  as they are suppose too.
hazards come on and both indicator lights flash as suppose to.

thank you for your help.

Offline RENOVATIONS

  • Administrator
  • Lifetime Member
  • *****
  • Posts: 10563
  • Referrals: 0
Re: Electrical Issue
« Reply #5 on: May 21, 2020, 05:02:06 PM »
How long has this been going on?
Any repairs at all made prior to this issue coming up?
Jeff

Projects:
_____________
1978 Trans Am
1970 Camaro
1970 'Cuda

Offline 79_455

  • Jr. Member
  • *
  • Posts: 40
  • Referrals: 0
Re: Electrical Issue
« Reply #6 on: May 22, 2020, 05:35:13 PM »
OK.. So first issue... your parking light on the left side has a bad ground so instead of grounding out at the radiator support .. its grounding back through your turn signal light.

Im sure that light when your turn your headlights on the front parking left parking light will not be working.

Thats why the turn signal indicator is staying on, in the dash as its the easiest ground that the signal can find.
Check both grounds.. on both sides of the radiator support  (clean them with very fine abrasive and make sure the radiator support is rust free where they bolt in....and pull the bulb out of the socket and make sure its good and clean out the socket...

That should fix the issue.. Let me know what happens and then we can address the tach, if thats still an issue.

D

Offline Stringer

  • Member
  • **
  • Posts: 141
  • Referrals: 0
Re: Electrical Issue
« Reply #7 on: May 22, 2020, 05:52:23 PM »
Is this a problem that recently started, with everything attached, or have you taken apart the dash or done any work?

Offline rbolte10

  • Jr. Member
  • *
  • Posts: 7
  • Referrals: 0
Re: Electrical Issue
« Reply #8 on: May 27, 2020, 11:18:04 AM »
So nothing has changed, i haven't done any recent work to the car at all.  It started late last summer and then i stored if for winter, now getting her back out and trying to figure out where to attack this problem from.

Offline 79_455

  • Jr. Member
  • *
  • Posts: 40
  • Referrals: 0
Re: Electrical Issue
« Reply #9 on: May 28, 2020, 12:04:53 AM »
have you tried all those functions i asked previous with the headlamp switch just with the parking lights on? Or does the problem occur only when the switch is completely pulled out and headlights on?

Are you able to reach under the dash and up to recede and reconnect the dash pcb cluster connector?