Author Topic: Wiring in the dash--  (Read 1684 times)

0 Members and 1 Guest are viewing this topic.

Offline Billy Brew

  • Jr. Member
  • *
  • Posts: 20
  • Referrals: 0
Wiring in the dash--
« on: October 13, 2007, 09:30:21 PM »
I have a 1977 Se-- when I turn up the rio stat setting on my head light switch to turn up my dash lights--which don't work--I can control the water temp needle and oil pressure needle in their gauges by turning them up or down by the rio stat switch. Also, when I turn on my blinker the water temp and oil pressure needles move side to side with the blinker???  Does anyone know what may be causing my problems? thanks
 
« Last Edit: October 13, 2007, 09:58:29 PM by Duke 77 »

Offline Joker (§ir£Ğragon)

  • Lifetime Member
  • *****
  • Posts: 4994
  • When you think it can't get any worse...God laughs
  • Referrals: 0
Re: Wiring in the dash--
« Reply #1 on: October 13, 2007, 10:01:31 PM »
Sounds like a short in the instrument cluster's printed circuit. Pretty common problem, although I'd say your's sounds like an extreme case.
Larry


Offline brian c

  • Lifetime Member
  • *****
  • Posts: 4880
  • Ohio Firebirds Member
  • Referrals: 0
    • Y88 Resto
Re: Wiring in the dash--
« Reply #2 on: October 14, 2007, 09:33:22 AM »
I wonder if you're missing a ground somewhere. Weird things happen in the dash when that ground is missing. Try running a ground from the back of your gauge pod to a good chassis ground and see if the problem goes away.

Good luck!

1978 Y88, '70 455 HO block bored 0.060, TH350, 3.42:1 gears...Oct '08 Fbodywarehouse Calendar - Woot!
1980 Firebird - no engine/tranny... to be pacecar clone

Offline Billy Brew

  • Jr. Member
  • *
  • Posts: 20
  • Referrals: 0
Re: Wiring in the dash--
« Reply #3 on: October 14, 2007, 11:05:31 AM »
thanks guys-- I will do try that.. :)