Author Topic: Wiper washer spraying  (Read 125 times)

0 Members and 1 Guest are viewing this topic.

Offline Jayua

  • Jr. Member
  • *
  • Posts: 4
Wiper washer spraying
« on: June 14, 2021, 02:57:16 PM »
1979 Trans Am, when I turn on the wipers, the washer sprays out both on low and high.  Itís a non delay system.  Trying to figure out if itís the switch, pump, or wiper motor.
Strange thing is that I unplugged the plug going into the washer pump, turned on the wipers and washer still sprays out.  Maybe some wires got crossed at some point over the years, or does this show a bad switch?
Any help is appreciated.

Offline Aus78Formula

  • Adv. Member
  • ****
  • Posts: 2528
Re: Wiper washer spraying
« Reply #1 on: June 15, 2021, 04:31:33 AM »
Luckily the non-delay switch is easier to find used to swap over and test. There was to be a reproduction but they cancelled it, not sure if anyone else picked up. Obviously, something is grounding when it shouldn't, or the opposite!

Offline Jayua

  • Jr. Member
  • *
  • Posts: 4
Re: Wiper washer spraying
« Reply #2 on: June 15, 2021, 04:06:50 PM »
Thanks for the reply, I really am trying to figure this out.  Felt pretty sure it was the switch, until I unplugged the wire on the pump and it still sprayed fluid, then it really has me baffled.
I guess Iím going to have to buy a switch in hopes that is the problem, if not guess I will have an extra switch.
Thanks again.

Offline b_hill_86

  • Sr. Member
  • ***
  • Posts: 740
  • Sterling to Starlight
Re: Wiper washer spraying
« Reply #3 on: June 15, 2021, 04:38:32 PM »
Wait, you unplugged the wire from the pump and it still sprays? Where is your pump located, on the bottle or on the wiper motor?
-Brian-

1977 Trans Am 400 4 speed hardtop

Offline Jayua

  • Jr. Member
  • *
  • Posts: 4
Re: Wiper washer spraying
« Reply #4 on: June 15, 2021, 09:22:43 PM »
Yes itís on the motor.

Offline b_hill_86

  • Sr. Member
  • ***
  • Posts: 740
  • Sterling to Starlight
Re: Wiper washer spraying
« Reply #5 on: June 16, 2021, 09:21:08 AM »
I could be wrong but I thought pulse wiper motors had the pump on the motor and non pulse had it on the bottle
-Brian-

1977 Trans Am 400 4 speed hardtop

Offline Jayua

  • Jr. Member
  • *
  • Posts: 4
Re: Wiper washer spraying
« Reply #6 on: June 17, 2021, 06:16:42 AM »
The 79s that Iíve seen they are all on the motor as far as I know.  I think Iím going to try replacing the switch to see if that works.