Author Topic: 1981 Formula Computer controlled carb and ignition problems.  (Read 425 times)

0 Members and 1 Guest are viewing this topic.

Offline TimBarb

  • Jr. Member
  • *
  • Posts: 19
Hi. I recently purchased a 1981 formula with about 95000 miles on the clock. The car was stored indoors for about 14 years . It was started and moved about every month or so, but was not driven on the road on any trips. It has the 4 speed with the 305 chevy engine. I had it shipped from Oregon to Illinois. I performed all the usual maintenance items--oils, filters, gear lube etc. The car started started and ran, but rough.-I changed  the cap, the rotor, plugs. plug wires, air and fuel filters.-Cleaned the carb. Ran a bit better but still a little rough. Exchanged the carb for a rebuilt unit . Had new true dual exhaust installed (deleted the cat). Replaced all the vacuum lines. The car has a backfire through the exhaust (mostly on deceleration and in between shifts) and appears to be running very rich--noted a wet soot actually deposited under the exhaust tips on the concrete floor and could smell the gas vapor. I noted no cracks in the exhaust manifolds and the exhaust is new. The only thing i have not done is check the timing.  The car starts well, and will run ok , but is inconsistent like the computer controlled carb is not receiving proper input signal.--Then the carb will either lack fuel and try to stall or will load up and run rich with the backfire. Really frustrating!!! I'm really considering pulling the computer controlled carb and distributor, installing a standard vacuum advance HEI , and carb. Looking for input on best way to go. Im guessing i would need a carb from a 1980 model with 305.If anyone else has had this [problem, please let me know what was your solution, and if it was to delete the computer controlled items, please let me know what part numbers I would need. ALSO--i was unable to locate info on how to use diagnostic read out on check engine. -Everything I found was for OBD II. I know there is a way too "jump" across " 2 OBD port terminals to read the code via flashing check engine lights, but i could find no info on which pins to jump. Thanks in advance for any help!!! Also replaced the fuel pump. Thanks again.
« Last Edit: June 23, 2020, 08:00:04 AM by TimBarb »